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1  About This Guide  

1.1 Purpose 

This manual describes Gowin FloorPlanner. It introduces the GUI and 

syntax of FloorPlanner in order to help you add physical constraints to your 

design. As the software is subject to change without notice, some 

information may not remain relevant and may need to be adjusted 

according to the software that is in use. 

1.2 Related Documents  

The latest user guides are available on GOWINSEMI Website: 

www.gowinsemi.com. You can find the related document: SUG100, Gowin 

Software User Guide. 

1.3 Terminology and Abbreviations  

 Table 1-1 shows the abbreviations and terminology that are used in 

this manual. 

Table 1-1 Terminology and Abbreviations  

Terminology and Abbreviations Meaning 

FPGA Field Programmable Gate Array 

I/O Input/Output 

SIP System in Package 

VREF Voltage Reference 

GUI Graphical User Interface 

IDE Integrated Development Environment 

https://www.gowinsemi.com/en/
http://cdn.gowinsemi.com.cn/SUG100E.pdf
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1.4 Support and Feedback  

Gowin Semiconductor provides customers with comprehensive 

technical support. If you have any questions, comments, or suggestions, 

please feel free to contact us directly by the following ways. 

Website: www.gowinsemi.com 

E-mail: support@gowinsemi.com 

https://www.gowinsemi.com/en/
mailto:support@gowinsemi.com
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2  Introduction  

FloorPlanner is a physical constraints editor and designed in-house by 

Gowin. It supports reading and editing the attributes and locations of I/O, 

Primitive, and Group, etc. It also supports the generation of place 

constraints files according to your configuration. These files define I/O 

attributes, as well as locations of primitives and modules. FloorPlanner 

provides easy and fast placement and constraint editing functions to 

improve the efficiency of writing physical constraint files, and provides 

timing optimization based on placement information and timing paths. 

The functions of FloorPlanner are as follows. 

 ̧ Supports the input of user design files & constraints files, editing 

constraints files, and the output of constraints files. 

 ̧ Supports the display of I/O Port, Primitive and Group constraints in 

user design files. 

 ̧ Can create, edit and modify constraints files. 

 ̧ Supports grid mode, macro cell mode and primitive mode of chip array. 

 ̧ Supports Package View. 

 ̧ Can display Chip Array and Package View synchronously. 

 ̧ Supports real-time display and differences display of constraints 

locations. 

 ̧ Can generate locations by dragging. 

 ̧ Supports I/O port configuration and batch configuration. 

 ̧ Supports display and editing function of Clock Assignment. 

 ̧ Supports constraints legality check. 

 ̧ Supports Back-annotate Physical Constraints. 

 ̧ Supports manual adjustment of timing.
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3  FloorPlanner GUI  

FloorPlanner can create and edit physical constraint files. It supports 

tabulated constraints editing and efficient netlist lookup so as to improve 

the efficiency of writing physical constraints files. 

3.1 Start FloorPlanner  

There are two ways to start FloorPlanner: 

1. Click "IDE > Tools" to open "FloorPlanner", as shown in Figure 3-1. 

Figure 3-1 Start FloorPlanner  via Menu Bar  

 

 

2. After synthesis, Double-click "FloorPlanner" in Process view, as shown 

in Figure 3-2. 
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Figure 3-2 Start FloorPlanner in Process View  

 

Note! 

 ̧ If you use Gowin FloorPlanner for constraints, the netlist file should be added first; 

 ̧ When you choose the first way to start Gowin FloorPlanner, the netlist file is needed 

to be loaded via clicking "File > New". 

 ̧ When you choose the second way to start Gowin FloorPlanner, the netlist file will be 

loaded automatically. 

3.2 FloorPlanner Interface  

Create or open FloorPlanner interface (including the netlist file), as 

shown in Figure 3-3. 

The interface displays menu, toolbar, Netlist, Project, Chip Array, 

Package View, and Message, etc. 
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Figure 3-3 FloorPlanner Interface  

 

3.2.1 Menu  Bar 

The menu bar includes "File", "Constraints", "Tools", "View", and 

"Help". 

File Menu  

File view is shown in Figure 3-4. 

Figure 3-4 File 

 

 

 ̧ New: Create constraints, add user design and select device, etc.  
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 ̧ Open: Open to add constraints, select part number, as shown in Figure 

3-5. 

 ̧ Reload: Physical constraints files, place files and timing path files can 

be reloaded after modifying. 

 ̧ Save: Save the modified files. 

 ̧ Save As: Save the modified file to a specified file and use the netlist 

name as the name of constraints file, which can be modified. 

 ̧ Exit: Exit FloorPlanner. 

Figure 3-5 Open Physical Constraints  

 
 

Tools Menu  

Tools view is shown in Figure 3-6.  

Back-annotate Physical Constraints: Back annotate each primitive and 

I/O place information to physical constraints file. 

Figure 3-6 Tools 

 

 

1. Click "Tools > Back-annotate Physical Constraints" to open a dialog 

box, as shown in Figure 3-7. Back-Annotate Physical Constraints is 

effective only when FloorPlanner is started in the project after Place & 

Route runs successfully. 

2. You can select one or more objects in the Back-annotate Physical 

Constraints dialog box. Click "OK" to open the "Save as" dialog box 

and print the place information to the physical constraint file. 

3. As shown in Figure 3-8, it is the generated physical constraints file 

when Port and Port Atrribute selected in Back-annotate Physical 

Constraints. 
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Figure 3-7 Back-annotate Physical Constraints  

 

 

Figure 3-8 Back-annotate Port 

 

Constraints Menu Bar  

Constraints menu bar is as shown in Figure 3-9. 

Figure 3-9 Constraints  

 

 

Primitive Constraints 

Right-click to select "Select Primitives" and a dialog box pops up, as 
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shown in Figure 3-10. 

1. You can select primitives by name or type. 

2. Click "OK" to generate the constraints and the constraints are 

displayed in "Primitive Constraints" at the bottom of main interface. 

3. You can set the location by typing or dragging in editing view. 

Note˻ 

The location is highlighted in light blue in Chip Array. 

Figure 3-10 Primitive Finder  

 
 

Group Constraints 

Group constraints include New Primitive Group and New Relative 

Group. 

Create Primitive Group. 

1. Create primitive group. Right-click to select "New Primitive Group" and 

a dialog box pops up, as shown in Figure 3-11. 

2. You can set Group name, Primitives locations and Exclusive. you can 

add and remove Primitives by clicking " " and " " buttons to 

create a right Primitive Group, as shown in Figure 3-12. 

Note! 

 ̧ Group name, Primitive, and Locations are required. 

 ̧ Locations can be inputted in the following ways: 

- Manually input 

- Before creating group constraints, copy the location and paste it into "New 

Primitive Group > Locations" in Chip Array window. 
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3. After finishing configuration, click "OK", and the syntax of the locations 

will be checked by the tool. 

- If the location is invalid, a prompt dialog box as Figure 3-13 and 

Figure 3-14 will pop up. You need to change the location. 

- If there is no error, click "OK", and the available location will be 

displayed in Chip Array. 

4. You can see the created group constraints in "Group Constraints". 

Double-click the group constraint, and Figure 3-12 pops up; you can 

edit the constraints. 

Figure 3-11 New Primitive Group  
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Figure 3-12 Right Primitive Group  

 

 

Figure 3-13 Invalid Locations  

 

 

Figure 3-14 Invalid Lo cations 

 

 

Create Relative Group. 

1. Create Relative Group constraints. Right-click to select "New Relative 

Group" and a dialog box pops up, as shown in Figure 3-15. 

2. You can set the group name, group members, and their relative 
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locations. You can add and remove primitives by " " and " " 

buttons. The created relative group constraints are shown in Figure 

3-16. 

Note! 

 ̧ Group name, Primitive, and Relative Location are required. 

 ̧ The locations can be inputted in the following ways: 

- Manually input 

- Before creating group constraints, copy the location and paste it to "New 

Relative Group > Relative Location" in Chip Array window. 

3. Click "OK" to generate the constraints. 

4. See the created constraints in "Group Constraints".Double-click the 

constraints, and a dialog box pops up, as shown in Figure 3-16; you 

can edit the constraints.  

Figure 3-15 New Relative Group  

  

 

Figure 3-16 Right Relative Group  
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Resource Reservation 

1. Create Resource Reservation constraints. Click Reserve Resources to 

create a new constraint in "Resource Reservation" window at the 

bottom of the interface. 

2. You can type the locations or by dragging. 

3. Double-click "Attribute" or click the "Attribute" column drop-down box to 

set the attribute of the reserved locations, as shown in Figure 3-17. 

Note! 

Name is used to distinguish reserved constraints. The name cannot be modified. 

Figure 3-17 Resource Reservation 

 

 

Clock Assignment 

Create global clock constraints and the number of constraints is limited̕

and the constraints validity will be checked. Right-click to select "Clock 

Assignment" and a dialog box pops up, as shown in Figure 3-18. You can 

perform the following operations. 

1. Click " " to select the corresponding Net. 

2. Select "BUFG", "BUFG[0]~[7]", "BUFS" and "LOCAL_CLOCK" via 

"Type" drop-down list. 

3. Configure Signal via "CE" and "CLK". After finished, click "OK" to 

generate constraints in "Clock the Assignment". Double-click to open 

the dialog box for editing. 

Note! 

When LOCAL_CLOCK selected, the signal check box is grayed. 
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Figure 3-18 Clock Assignment  

 

 

Quadrant Constraints 

Create DCS and DQCE clock quadrant constraints. Constrain the 

specified instance to the specific quadrant according to the chip quadrants 

distribution. Right-click to select "Quadrant Constraints" and a dialog box 

pops up, as shown in Figure 3-19 and Figure 3-20. The related operations 

are as follows. 

1. Select the corresponding DCS/DQCE primitive by clicking " ". If 

there are no DCS/DQCE primitives in the design, you can not add. 

2. Configure quadrant positions via the check boxes under "Position". 

3. Click "OK" to generate constraints, which will be displayed in the 

"Quadrant Constraints" window. You can double-click to open the 

dialog box for editing. 

Figure 3-19 Quadrant Constraints  (GW1N -1) 
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Figure 3-20 Quadrant Constraints (GW2A -18) 

 

 

Hclk Constraints 

Create HCLK primitives constraints and specify the constraint 

locations on the device. Right-click to select "Hclk Constraints" and a dialog 

box pops up, as shown in Figure 3-21. The related operations are as 

follows. 

1. You can select a primitive by clicking " ". If there are no 

corresponding primitives in the design, you can not add. 

2. Configure quadrant positions via the check boxes under "Positionò. 

3. Click "OK" to generate constraints, which will display in "Hclk 

Constraints" window. You can double-click to open the dialog box for 

editing. 

Note! 

The available positions are different due to different devices in project, and the unavailable 

positions are greyed.  

Figure 3-21 Hcl k Constraint  

 

 

Vref Constraints 

Create Vref Driver to configure IO Port Vref; right-click and select 

"Define Vref Driver" to create a new constraint in the "Vref Constraints" 

window, as shown in Figure 3-22. 
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Figure 3-22 Vref Constraints  

  

Note! 

 ̧ Specify the location of Vref by dragging. 

 ̧ Modify Vref name by double-clicking. 

Finder 

You can quickly find Primitive, IO Port, and edit the corresponding 

constraints by right-clicking; a dialog box pops up by clicking "Find", as 

shown in Figure 3-23. The related operations are as follows. 

 ̧ You can find primitives or ports by selecting "Primitives" or "Ports". 

 ̧ You can right-click the corresponding item and select "Edit Primitive 

Constraint" to create constraints. 

Figure 3-23 Find er Dialog Box  
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View  Menu  

As shown in Figure 3-24, View includes Toolbars, Windows, Zoom In, 

Zoom Out and Zoom Fit. The description of these sub-menus is as follows. 

 ̧ Toolbars: Display shortcuts 

 ̧ Windows: Display different windows, as shown in Figure 3-25 

 ̧ Zoom In: Zoom in Chip Array or Package View 

 ̧ Zoom Out: Zoom out Chip Array or Package View 

 ̧ Zoom Fit: Zoom in/out Chip Array or Package View according to the 

window size. 

Figure 3-24 View  

 

 

Figure 3-25 Windows  

 

Help  Menu  

Help is used to provide software version and copyright information. 



3 FloorPlanner GUI 3.2 FloorPlanner Interface 

 

SUG935-1.3E 18(73) 

 

3.2.2 Summary  and Netlist Window s 

Summary and Netlist windows display device, part number, user 

design, constraints path and netlist, etc. 

Summary  Window  

The summary window is shown in Figure 3-26. It displays the 

information of device, part number, design files and constraints files. 

Figure 3-26 Summary  Window  

 

 

Netlist Window  

As shown in Figure 3-27, Netlist window displays Ports, Primitives, 

Nets, Module, and timing paths. 

Note! 

 ̧ The Ports and Primitives names are displayed in full path and sorted in alphabetical 

ascending order by default. 

 ̧ Port and Net display via Bus and non-Bus, as shown in Figure 3-28. 

 ̧ Modules are displayed in hierarchy and the number of instances in each module is 

also displayed, as shown in Figure 3-29. 

 ̧ The timing path is listed in the ascending order of slack, as shown in Figure 3-30. 
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Figure 3-27 Netlist Window  
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Figure 3-28 BUS and Non -Bus Display  

 

Figure 3-29 Hierarchy Display  
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Figure 3-30 Timing Paths  

 

 

Netlist provides right-click menu as shown below. 

 ̧ Highlight: Highlight the corresponding constraint location in Chip Array. 

 ̧ Edit Constraint: Edit the corresponding constraints. 

Note! 

If the current Primitive or Port has no constraints locations, the highlight is not available, as 

shown in Figure 3-31. 
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Figure 3-31 Netlist Right -clicking  

 

3.2.3 Package View 

As shown in Figure 3-32 , taking GW1NRF-4B-QFN48 as an example, 

Package View displays I/O, supply pin, and ground pin based on chip 

package. When the mouse is placed on a location, the I/O type, bank, and 

LVDS will display. 
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Figure 3-32 Package View (GW1NRF -4B-QFN48) 

 
 

Various symbols and colors are used to distinguish user I/Os, power 

supply pins and ground pin. The colors of IO pins of different BNAKS are 

different, as shown below. 

 ̧ " ": User I/O 

 ̧ " ": VCC 

 ̧ " ": VSS 

 ̧ " ": Bluetooth interface 

The right-click menu supported by the Package View is shown in 

Figure 3-33. The descriptions are as follows. 

 ̧ Zoom In: Zoom in Package View 

 ̧ Zoom Out: Zoom out Package View 

 ̧ Zoom Fit: Zoom in/out Package View to fit window size 

 ̧ Show Differential IO Pairs: Display differential pair. As shown in Figure 

3-34, a differential pair is connected by a red line. 

 ̧ Top View: Package View is displayed in the top view by default. The top 

view of GW1N-9-WLCSP64 with coordinate origin at the top left corner 

is as shown in Figure 3-35; and the top view of GW1N-9-WLCSP81M 

package with coordinate origin at the top right corner as shown in 
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Figure 3-37. 

 ̧ Bottom View: The bottom view of GW1N-9-WLCSP64 with coordinate 

original at the bottom right corner is as shown in Figure 3-36; and the 

bottom view of GW1N-9-WLCSP81M with coordinate original at the 

bottom left is as shown in Figure 3-38. 

Figure 3-33 Package View Right -clicking  

 

 

Figure 3-34 Differential Pair Display  
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Figure 3-35 Top View  

 

 

Figure 3-36 Bottom View  
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Figure 3-37 GW1N -9-WLCSP81M Top View  

 
 

Figure 3-38 GW1N -9-WLCSP81M Bottom View  

 

 

Package View supports the display of IO Port constraint locations, and 

the IO Port can be constrained by dragging from the Netlist or I/O 

Constraints to the Package View window. When dragged, the port name 

will be displayed; the unconstrianted pins are grayed out and not dragged. 
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3.2.4 Chip Array Window  

The Chip Array window of FloorPlanner is shown in Figure 3-39. Chip 

Array displays I/O, CFU, CLU, DSP, PLL, BSRAM, and DQS according to 

the row and column information of the chip, supports real-time display of all 

constraints locations, and also supports the functions of zoom in/out and 

dragging, etc. 

I/O denotes all I/O locations of die and is distinguished with different 

colors. 

 ̧ White: Bonded out I/O location 

 ̧ Red: Unbonded I/O location 

 ̧ Blue: If it is a SIP device, such as GW2AR-18, GW1NR-4, GW1NR-9, 

GW1NSR-2C, there will be blue marked I/O. 

Figure 3-39 Chip Array Window  

 
 

Chip Array provides grid mode, macrocell mode, and primitive mode. 

 ̧ Grid mode: Display constraints locations in grid, as shown in Figure 

3-40. 

 ̧ Macrocell mode: Display constraints locations in CLS, IOBLK, as 

shown in Figure 3-41. 
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 ̧ Primitive mode: Display constraints locations in REG, LUT etc., as 

shown in Figure 3-42. 

Figure 3-40 Constraints in Grid  

 

 

Figure 3-41 Constraints in Macrocell  
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Figure 3-42 Constraints in Primitive  

 

 

Chip Array supports following dragging functions. 

 ̧ Drag from Netlist to Array to generate constraints and specify 

constraints location. 

 ̧ Drag from Editing to Array to specify constraints location. 

There is a chip sub-window in Chip Array for real-time display of the 

current view relative to the device. Drag the white frame in the chip 

sub-window to move Chip Array. Chip Array distinguishes constraints type 

and displays constraints locations in different colors. The color meaning is 

as follows. 

 ̧ White: Display constraints location being selected or highlighted. 

 ̧ Dark blue: Display reserved constraints, indicating that the location 

cannot be occupied again. 

 ̧ Light blue: Display IO and Primitive constrained in a grid or range. 

Chip Array supports right-clicking functions are as follows. 

 ̧ Zoom In: Zoom in Chip Array 

 ̧ Zoom Out: Zoom out Chip Array 

 ̧ Zoom Fit: Zoom in/out Chip Array to fit the window size 

 ̧ Show Constraints View: Show instances constraints view of Chip Array 

 ̧ Show Place View: Show instances place view of Chip Array; it is only 

effective when FloorPlanner is started after running Place & Route. 

Otherwise, it is greyed out. 

 ̧ Show Multi-View: Show instances constraints and place views of Chip 
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Array; it is only effective when FloorPlanner is started after running 

Place & Route. Otherwise, it is greyed out. 

 ̧ Show In-Out Connection: Show and select the input and output 

connection of the instance in the Place View; it can only be used if an 

instance is selected when Show Place View > All Instance view opens. 

Otherwise, it is greyed out. 

 ̧ Show In Connection: Show and select the input connection of the 

instance in the Place View; it can only be used if an instance is 

selected when Show Place View > All Instance view opens. Otherwise, 

it is greyed out. 

 ̧ Show Out Connection: Show and select the output connection of the 

instance in the Place View; it can only be used if an instance is 

selected when Show Place View > All Instance view opens. Otherwise, 

it is greyed out. 

 ̧ Convert Place To Constraints: Convert the place information of the 

selected instance to constraint information in the Place View; it can 

only be used if an instance is selected when Show Place View > All 

Instance view opens. Otherwise, it is greyed out. 

 ̧ Unhighlight All: Remove highlight. 

 ̧ Copy Location: Copy the selected location or area; If GRID and Block 

are selected, "Copy Location" in right-click menu is available. 

Otherwise, it is unavailable, as shown in Figure 3-43. 

Show Place View also shows Lut and Reg density, as shown in Figure 

3-44. 

 ̧ ALL Instance: Show place of all instances. Light green indicates less 

than five, green indicates six to ten, and dark green indicates more 

than ten. 

 ̧ Only Lut: Shows place of all Lut. Light green indicates less than two, 

green indicates three to four, and dark green indicates more than four. 

 ̧ Only Dff: Shows place of all Reg. Light green indicates less than two, 

green indicates three to four, and dark green indicates more than four. 

You can view the place of all instances in the design by clicking Show 

Place View > ALL Instance. 

 ̧ Hover the mouse over the instance place location in the Chip Array 

window to display the name of the instance, as shown in Figure 3-45. 

 ̧ Select a specific instance in the Netlist window; right-click and select 

"Highlight", the place location of that instance will be highlighted, as 

shown in Figure 3-46. 
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Note! 

You can select an area by "Ctrl" + left mouse button; right click and select "Copy Location", 

you can copy the location and paste it to any constraint editing window. 

Figure 3-43 Chip Array Right -clicking  

 

 



3 FloorPlanner GUI 3.2 FloorPlanner Interface 

 

SUG935-1.3E 32(73) 

 

Figure 3-44 Show Place View  

 

 

Figure 3-45 Mouse Hovering  Display  

 


















































































